[Netarchivesuite-users] wrong checksum

Kåre Fiedler Christiansen kfc at statsbiblioteket.dk
Mon May 26 20:20:02 CEST 2008


On Mon, 2008-05-26 at 19:41 +0200, Peter Moser wrote:
> Hello!
> 
> I've got following warning in the systemmonitor. How critical is it? Are 
> the stored arc-Files consistant?

It does sound serious. This message should only show up if the files
have changed the checksum after the first initial upload! Something
seems to have tampered with the files on your disk.

How does your installation look? Do you have a replicated archive? In
that case you should be able to recover from this situation using the
bit preservation tools. Otherwise you may have to try to manually figure
out if your arc files are okay. Do you have a backup you can compare
with?

> Obviously the system is missing some files. Did heritrix terminate 
> correctly or not. In the job monitor the job is still "started", 
> although no heritrix instance is running anymore.
> What can I do?

I think in this case the reason you have this problem is the lost
connection you reported earlier. The database update that should have
marked the job 'done' or 'failed' failed to update the database.
Currently, unfortunately you cannot recover from this situation from
within the system. You can shut down the system and manually update the
stattus field of the 'jobs' table in the database. or you can ignore the
seemingly started job - it's harmless.

However, this should not cause the warning you see below. That warning
seems to indicate something has changed on disk.

The bit preservation interface should show you more.

> Thanks in advance for your hints!

I hope this covers your questions, otherwise I will gladly try to
elaborate.

Best,
  Kåre




More information about the NetarchiveSuite-users mailing list