[Netarchivesuite-devel] Hiccup with NetarchiveSuite Quick Start

Pranay Pramod ppramod at caci.com
Thu Mar 22 21:42:07 CET 2012


Hi Søren,

Thanks for the prompt reply!
Strange enough, no logs are being produced, whatsoever.

However, I realized that my JAVA_HOME was pointing to an older version "1.5.0" of java.
Correcting it to point to 1.6.0_30  took away the exception and the installation seemed to have gone fine.

But I think I still am missing something on the configuration settings.
As per the Quick Start Manual 3.14, when I setup the browser to proxy on 8070, and try to access localhost:8074/HarvestDefintion
the application is unable to connect - firefox can't establish a connection to the server at localhost:8074

Accessing the below two URLs makes me think that the application is up and running and I might be closer.

1)      When I access http://localhost:7676, this is what I get in the browser response

101 imqbroker 4.5.2

cluster_discovery tcp CLUSTER_DISCOVERY 0

portmapper tcp PORTMAPPER 7676 [imqvarhome=/home/ppramod/netarchive/mq/bin/var/mq,imqhome=/home/ppramod/netarchive/mq/bin/mq,sessionid=165848392499946496]

jmxrmi rmi JMX 0 [url=service:jmx:rmi://strontium/stub/rO0ABXNyAC5qYXZheC5tYW5hZ2VtZW50LnJlbW90ZS5ybWkuUk1JU2VydmVySW1wbF9TdHViAAAAAAAAAAICAAB4cgAaamF2YS5ybWkuc2VydmVyLlJlbW90ZVN0dWLp/tzJi+FlGgIAAHhyABxqYXZhLnJtaS5zZXJ2ZXIuUmVtb3RlT2JqZWN002G0kQxhMx4DAAB4cHc0AAtVbmljYXN0UmVmMgAACTEyNy4wLjEuMQAAnCMjKFPEaTH9yKmwWcAAAAE2O/mI3oABAHg=]

admin tcp ADMIN 53443

jms tcp NORMAL 48625



2)      When I access any non-specific URL like google.com<http://localhost:7676>, this is what I get in the browser



Internal server error for: http://google.com/

dk.netarkivet.common.exceptions.IOFailure: No index set while searching for 'http://google.com/'

                at dk.netarkivet.common.distribute.arcrepository.ARCLookup.luceneLookup(ARCLookup.java:196)

                at dk.netarkivet.common.distribute.arcrepository.ARCLookup.lookup(ARCLookup.java:139)

                at dk.netarkivet.viewerproxy.ARCArchiveAccess.lookup(ARCArchiveAccess.java:127)

                at dk.netarkivet.viewerproxy.NotifyingURIResolver.lookup(NotifyingURIResolver.java:72)

                at dk.netarkivet.viewerproxy.CommandResolver.lookup(CommandResolver.java:81)

                at dk.netarkivet.viewerproxy.CommandResolver.lookup(CommandResolver.java:81)

                at dk.netarkivet.viewerproxy.CommandResolver.lookup(CommandResolver.java:81)

                at dk.netarkivet.viewerproxy.WebProxy.handle(WebProxy.java:131)

                at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)

                at org.mortbay.jetty.Server.handle(Server.java:322)

                at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:542)

                at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:928)

                at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:549)

                at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:212)

                at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:404)

                at org.mortbay.jetty.bio.SocketConnector$Connection.run(SocketConnector.java:228)

                at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:582)



Any idea what might be going wrong now?

Thanks!
Pranay
Software Developer-II
CACI

From: Søren Vejrup Carlsen [mailto:svc at kb.dk]
Sent: Thursday, March 22, 2012 6:31 AM
To: netarchivesuite-devel at ml.sbforge.org
Cc: Pranay Pramod
Subject: SV: [Netarchivesuite-devel] Hiccup with NetarchiveSuite Quick Start

Hi Pranay.
Each application writes serious problems it encounters during startup to a file called start_Application.log
In this case you should look at the file start_ViewerProxyApplication.log found in the root of the installation directory.
This should give you a clue to what the problem is. If it doesn't say you anything, send the logfile to me.

Best Regards
Søren Vejrup Carlsen
Developer of Netarchivesuite

Fra: netarchivesuite-devel-bounces at ml.sbforge.org<mailto:netarchivesuite-devel-bounces at ml.sbforge.org> [mailto:netarchivesuite-devel-bounces at ml.sbforge.org] På vegne af Pranay Pramod
Sendt: 21. marts 2012 21:36
Til: netarchivesuite-devel at ml.sbforge.org<mailto:netarchivesuite-devel at ml.sbforge.org>
Emne: [Netarchivesuite-devel] Hiccup with NetarchiveSuite Quick Start


Hello Group,

I am trying to setup the NetarchiveSuite on a linux (ubuntu) box following the instructions from http://netarchive.dk/suite/Quick%20Start%20Manual%203.14.

While all the steps seem to go OK, running the startall_NATIONAL_LIBRARY.sh script throws an exception in thread "main" starting the last application - ViewerProxyApplication.
Starting linux application: ViewerProxyApplication
Exception in thread "main" --------------------------------------------

And I suspect, consequently, the proxy configuration doesn't work as expected.

No log entry is generated for this exception and thus little harder for me to figure out what exactly is going wrong.

Would appreciate any help on this!

Regards,
Pranay


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://ml.sbforge.org/pipermail/netarchivesuite-devel/attachments/20120322/1251c888/attachment-0001.html>


More information about the Netarchivesuite-devel mailing list