[Netarchivesuite-users] NAS/Heritrix doesn't obey byte limits

Bjarne Andersen bja at kb.dk
Mon Mar 18 11:06:32 CET 2019


I wonder weather the logic around limits and domains have changed at some point so that objects that are in-lined (like images) are counted as belonging to a specific domain thus the limit will be reached not only by objects from the specific domain Itself but most likely sooner by other in-lined objects from other domains. I know this was a feature-request in older versions of NetarchiveSuite but I haven’t followed the development that close in later years.

 

Domains going over the limit could be a result of very large objects fetched as some of the last objects from that domain (e.g. a 2Gb video-file) – the crawl.log should reveal that.

 

Best

Bjarne

 

From: NetarchiveSuite-users <netarchivesuite-users-bounces at ml.sbforge.org> On Behalf Of Tue Hejlskov Larsen
Sent: Monday, March 18, 2019 10:07 AM
To: netarchivesuite-users at ml.sbforge.org
Subject: Re: [Netarchivesuite-users] NAS/Heritrix doesn't obey byte limits

 

Hello Peter

 

What does your crawllogs tell you?

 

Best regards

Tue

 

From: NetarchiveSuite-users <netarchivesuite-users-bounces at ml.sbforge.org <mailto:netarchivesuite-users-bounces at ml.sbforge.org> > On Behalf Of Peter Svanberg
Sent: Monday, March 18, 2019 12:07 AM
To: netarchivesuite-users at ml.sbforge.org <mailto:netarchivesuite-users at ml.sbforge.org> 
Subject: [Netarchivesuite-users] NAS/Heritrix doesn't obey byte limits

 

Hello, NAS users and others!

 

We are experiencing a very strange behavior from NAS/Heritrix (see attached Excel file, with comments):

 

The harvests reports says ”Stopped due to … byte/object limit reached" at very different levels – sometimes much above (more than five times the limit), sometimes much below the limit. We fail to see any pattern in this, it seems more or less random.

 

What are we doing wrong? Is it some error in the harvest template? (Attached below each table.)

 

Or, if it is some kind of bug, are there workarounds?

 

We would much appreciate any hints, as this is quite a problem for us, both for the on-going selective harvests and the upcoming big snapshot run!

 

(We are running version 5.4.2, I hope that it doesn’t affect this problem, as we can’t upgrade now.)

 

Best regards,

-----

Peter Svanberg
Technical officer
Digital Collections Department, Newspapers, Radio and Television Division 

National Library of Sweden
PO Box 5039 <x-apple-data-detectors://1/1>  
SE-104 51 Stockholm <x-apple-data-detectors://1/1> 
Visits: Karlavägen 100, Stockholm <x-apple-data-detectors://2>  
Phone <x-apple-data-detectors://2> : +46 10 709 32 78

E-mail: peter.svanberg at kb.se <mailto:peter.svanberg at kb.se> 
Web: www.kb.se <http://www.kb.se/> 

 

 

 

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://ml.sbforge.org/pipermail/netarchivesuite-users/attachments/20190318/060c84a5/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 5219 bytes
Desc: not available
URL: <https://ml.sbforge.org/pipermail/netarchivesuite-users/attachments/20190318/060c84a5/attachment-0001.p7s>


More information about the NetarchiveSuite-users mailing list